Quantcast

pgAgent installation fails - LIBPQ.DLL is missing - PostgreSQL 9.0.2 x64 - 2008 Windows Server x64

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

pgAgent installation fails - LIBPQ.DLL is missing - PostgreSQL 9.0.2 x64 - 2008 Windows Server x64

Stane Mikolič
Hello,

I have a problem with installing pgAgent on my Windows server.

1. Installed PostgreSQL 9.0.2 without errors with one click installer
for windows "postgresql-9.0.2-1-windows_x64"

2. pgAdmin III successfully connects to postgres database with
password provided in instalation

3. script pqagent.sql executes without errors

4. script pqagent_update.sql executes with warning: [WARNING  ] ALTER
TABLE pgagent.pga_jobstep ADD COLUMN jstconnstr text NOT NULL DEFAULT
'' CONSTRAINT pga_jobstep_connstr_check CHECK ((jstconnstr != '' AND
jstkind = 's' ) OR (jstconnstr = '' AND (jstkind = 'b' OR jstdbname !=
'')))
            ERROR:  column "jstconnstr" of relation "pga_jobstep" already exists

5. jobs node shows in pgAdmin explorer tree

6. But when I try to install pgAgent

       C:\Program Files\pgAgent\pgAgent INSTALL pgAgent -u postgres -p
secret hostaddr=127.0.0.1 dbname=postgres user=postgres
password=secret

I get an error message saying:

       The program can't start because LIBPQ.DLL is missing from your
computer. Try reinstalling the program to fix this problem.

I tried looking for the libpq.dll.
 - libpq.dll is present in postgresql bin directory
 - if i copy .dll file to pgAgent directory i get a different error...
something with 0000x001
 - same error if I copy pgAgent to bin directory

I tried x32 instalation of postgresql 9.0.2 with all DB drivers from
Stack builder - I get the same

My instalation on os x 1.6.x works fine - i got it up and running in no time.

Am I missing something? What do you make of it? Any suggestions /
solutions are welcome.

Best regards. S


-- System --

Processor: Intel(R) Xeon(R) CPU E5420 @ 2.50GHz
Instaled Memory: 1GB
System type: 64 bit Operating System

-- Windows Edition --

Windows Server R 2 Enterprise

System updates: all updates installed

-- Database --

Installed (in this order)

- postgresql-9.0.2-1-windows_x64
in C:\Program Files\PostgreSQL\9.0

DB drivers installed from Stack Builder:
- C:\Program Files (x86)\PostgreSQL\pgJDBC
- C:\Program Files (x86)\PostgreSQL\Npgsql
- C:\Program Files (x86)\PostgreSQL\psqlODBC

pgagent.sql script - (tried instaling pgAgent - missing .dll error)

pgagent_upgrade.sql script - (tried instaling pgAgent - same missing .dll error)

when running pgagent_upgrade.sql script I get the following warning:

[WARNING  ] ALTER TABLE pgagent.pga_jobstep ADD COLUMN jstconnstr text
NOT NULL DEFAULT '' CONSTRAINT pga_jobstep_connstr_check CHECK
((jstconnstr != '' AND jstkind = 's' ) OR (jstconnstr = '' AND
(jstkind = 'b' OR jstdbname != '')))
            ERROR:  column "jstconnstr" of relation "pga_jobstep" already exists

--
Sent via pgadmin-support mailing list ([hidden email])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-support
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: pgAgent installation fails - LIBPQ.DLL is missing - PostgreSQL 9.0.2 x64 - 2008 Windows Server x64

Piotr Czekalski
Hello there.

I was facing the same problem.
I think the real reason is PgAgent is an x86 code, actually running with means of WoW on your x64 Windows System, while Postgres 9.x is truly x64 now thus you do have a LIBPQ.DLL byt 64bit one, while PgAgent is looking for x86 one.

I've found the following workaround.
Install somwhere else x86 version of PostgreSQL for Windows (actually I've used an old 8.4.1 form our old server), copy the following libraries:

comerr32.dll, gddapi32.dll, iconv.dll, k5sprt32.dll, krb5_32.dll, libeay32.dll,. libiconv-2.dll, libintl-8.dll, libpq.dll, libxml2.sll, libxslt.dll, msvcr71.dll, ssleay32.dll, zlib1.dll

to the folder where PgAgent is located.
This way I made it working. Looking forward for x64 release of PgAgent (currently unavailable I think).

Regards,

Piotr Czekalski

TECHBAZA.PL Development Team.

-- 

--------------------------------------------------------------
"TECHBAZA.PL" Sp. z o.o.
Technologie WEB, eDB & eCommerce
Oddział Gliwice
ul. Chorzowska 50
44-100 Gliwice
tel. (+4832) 7186081
fax. (+4832) 7003289
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: pgAgent installation fails - LIBPQ.DLL is missing - PostgreSQL 9.0.2 x64 - 2008 Windows Server x64

Piotr Czekalski

Some more information -when you finally make it working remember that your service is WoW one, thus you won't be able to see that in regular service manager.

To install PgAgent run "C:\Program Files\pgAdmin III\pgAgent.exe" INSTALL pgagent –u OSUser –p OSUSerPassword <connect-string>
Watch registry (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\pgAgent) to see cofiguration details and acknowledge correct install.
To manage service, use:
net start pgagent – to start service
net stop pgagent – to stop service.

Hope that helps,

Piotr

W dniu 2011-01-21 21:58, Piotr Czekalski pisze:
Hello there.

I was facing the same problem.
I think the real reason is PgAgent is an x86 code, actually running with means of WoW on your x64 Windows System, while Postgres 9.x is truly x64 now thus you do have a LIBPQ.DLL byt 64bit one, while PgAgent is looking for x86 one.

I've found the following workaround.
Install somwhere else x86 version of PostgreSQL for Windows (actually I've used an old 8.4.1 form our old server), copy the following libraries:

comerr32.dll, gddapi32.dll, iconv.dll, k5sprt32.dll, krb5_32.dll, libeay32.dll,. libiconv-2.dll, libintl-8.dll, libpq.dll, libxml2.sll, libxslt.dll, msvcr71.dll, ssleay32.dll, zlib1.dll

to the folder where PgAgent is located.
This way I made it working. Looking forward for x64 release of PgAgent (currently unavailable I think).

Regards,

Piotr Czekalski

TECHBAZA.PL Development Team.

-- 

--------------------------------------------------------------
"TECHBAZA.PL" Sp. z o.o.
Technologie WEB, eDB & eCommerce
Oddział Gliwice
ul. Chorzowska 50
44-100 Gliwice
tel. (+4832) 7186081
fax. (+4832) 7003289


-- 

--------------------------------------------------------------
"TECHBAZA.PL" Sp. z o.o.
Technologie WEB, eDB & eCommerce
Oddział Gliwice
ul. Chorzowska 50
44-100 Gliwice
tel. (+4832) 7186081
fax. (+4832) 7003289
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: pgAgent installation fails - LIBPQ.DLL is missing - PostgreSQL 9.0.2 x64 - 2008 Windows Server x64

Stane Mikolič
Hello,

Piotr, your workaroudn works like magic.

What I did...

1. install 9.0.2 x32 on the same machine
2. copy the files from your list to pgAgent folder --> except
comerr32.dll which I couldn't find on my system.
3. uninstal x32 version
4. run "C:\Program Files\pgAdmin III\pgAgent.exe" INSTALL pgagent -u
OSUser -p OSUSerPassword <connect-string>

   - as OSuser I used postgres user which was created during the
installation. I tried with Administrator user but service failed due
to logon

   running from pgAgent director the command was: pgAgent.exe INSTALL
pgAgent -u postreg -p my_password hostaddr=127.0.0.1 dbname=postgres
user=postgres password=my_password

5. net start pgagent

Works like a charm!

Thank you for your help.

Regard, Stane



On Fri, Jan 21, 2011 at 10:08 PM, Piotr Czekalski
<[hidden email]> wrote:

>
> Some more information -when you finally make it working remember that your
> service is WoW one, thus you won't be able to see that in regular service
> manager.
>
> To install PgAgent run "C:\Program Files\pgAdmin III\pgAgent.exe" INSTALL
> pgagent -u OSUser -p OSUSerPassword <connect-string>
> Watch registry
> (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\pgAgent) to see
> cofiguration details and acknowledge correct install.
> To manage service, use:
> net start pgagent - to start service
> net stop pgagent - to stop service.
>
> Hope that helps,
>
> Piotr
>
> W dniu 2011-01-21 21:58, Piotr Czekalski pisze:
>
> Hello there.
>
> I was facing the same problem.
> I think the real reason is PgAgent is an x86 code, actually running with
> means of WoW on your x64 Windows System, while Postgres 9.x is truly x64 now
> thus you do have a LIBPQ.DLL byt 64bit one, while PgAgent is looking for x86
> one.
>
> I've found the following workaround.
> Install somwhere else x86 version of PostgreSQL for Windows (actually I've
> used an old 8.4.1 form our old server), copy the following libraries:
>
> comerr32.dll, gddapi32.dll, iconv.dll, k5sprt32.dll, krb5_32.dll,
> libeay32.dll,. libiconv-2.dll, libintl-8.dll, libpq.dll, libxml2.sll,
> libxslt.dll, msvcr71.dll, ssleay32.dll, zlib1.dll
>
> to the folder where PgAgent is located.
> This way I made it working. Looking forward for x64 release of PgAgent
> (currently unavailable I think).
>
> Regards,
>
> Piotr Czekalski
>
> TECHBAZA.PL Development Team.
>
> --
>
> --------------------------------------------------------------
> "TECHBAZA.PL" Sp. z o.o.
> Technologie WEB, eDB & eCommerce
> Oddział Gliwice
> ul. Chorzowska 50
> 44-100 Gliwice
> tel. (+4832) 7186081
> fax. (+4832) 7003289
>
> --
>
> --------------------------------------------------------------
> "TECHBAZA.PL" Sp. z o.o.
> Technologie WEB, eDB & eCommerce
> Oddział Gliwice
> ul. Chorzowska 50
> 44-100 Gliwice
> tel. (+4832) 7186081
> fax. (+4832) 7003289

--
Sent via pgadmin-support mailing list ([hidden email])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgadmin-support
Loading...